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Procedure

Configuring Server 2012 for IIS and IDVM

e Make sure that the Pre-Requisites are installed before starting the configurations in Programs and
features
e How to Enable .Net Framework 3.5 on Microsoft Windows Server 2012
o Ifthe serveris connected to the internet and it has Windows update enabled, the framework
can be pulled from the internet and added to the Windows installation folder by the OS when
enabling the feature.
m On Server 2012 R2 this is a non-issue as it is already installed

e Go to Programs and Features - this will take you to the Roles and Features wizard for Server
2012
o Enable Web Server (IIS) in Server Roles and the following features inside of it
s Common HTTP Features
s Default Document
= Directory Browsing
s HTTP Errors
= Static Content
s HTTP Redirection
o Health and Diagnostics
= HTTP Logging
o Performance
m Static Content Compression
Security
o Request Filtering

o Windows Authentication
Application and Development

o .NET Extensibility 3.5

o .NET Extensibility 4.5

o ASP .NET 35

o ASP .NET 4.5
ISAPI Extensions

o ISAPI Filters
Management Tools

o IS Management Console

o

o |IS6 Management Compatibility
® |IS 6 Metabase Compatibility
= [IS6 WMI Compatibility

I1IS Management Scripts and Tools



Management Service

Continue to Features and ensure the following is Enabled:
o .NET Framework 3.5 Features
= HTTP Activation
.NET Framework 4.5 Features
o .NET Framework 4.5
o ASP.NET 4.5
o WCF Services
s HTTP Activation

Install the LS Application Server

o If OnGuard is already installed click Modify from the installer after opening Setup.exe on the
installation media, expand out Server Applications and select the Application Server to be
installed on the local disc.
NOTE: DO NOT UNCHECK ANY OF THE OTHER OPTIONS, DOING SO WILL UNINSTALL
ONGUARD

o IfOnGuard is not yet installed, the Platform installation option will install OnGuard and the LS
Application Server Service

e Run FormsTranslator (Lnl.Tools.FormTranslator.exe) from the root of OnGuard
o Note: If Platform install was done in the above step this can be skipped as FormsTranslator
runs automatically at the end of Database Setup

e Create an admin account for the LS Application Server
o Ifthe system is on a domain then use a domain user who is also a Local Admin

NOTE: if you plan to use IDVM Host Application you must have a Domain and the account use must
belong to the Domain.

e To make the domain account a local admin:
o Right click on My Computer > Select Manage > Expand out Local Users and Groups
o Left mouse click on Groups (under Local Users and Groups) > Right click on the Administrators
Name > select properties
= Click [Add..]
s Click [Locations..] > select the domain as the location
s Click [Advanced..]
= Click [Find Now]
= Select the domain user from the list
= Click [OK]
e The 'Enter the object name to select' field should be populated now with domain\domain user >
Click [OK]



e Start the Application Server using the specific user account you created previously

)

o

)

o

Go to Start > Run > type services.msc
Right click on LS Application Server service > select properties
= Select the Log On tab > the radio button for 'This account!
s Click [Browse..]
= Click [Locations..] > select the local machine or domain as the location
= Click [Advanced..]
s Click [Find Now]
= Select LSApplication or domain user from the list
s Click [OK]
The 'Enter the object name to select' field should be populated now with
localMachineName\LSApplication or domain\domain user
= Click [OK]
Type the password for the LSApplication user 2 times (Password and Confirm Password fields)
= Click [OK]

e Add the SQL Login for the new user of the LS Application Server

)

)

Open SQL Management Studio Express > login with Windows Authentication or as SA if using
SQL Authentication
Expand Security in the Object Explorer
Right click on Logins > New Login...

= [Search..] located next the text field for Login name:
Click [Locations..] > select the local machine or domain as the location
Click [Advanced..]
Click [Find Now]
Select LSApplication or domain user from the list

s Click [OK]

Select the Windows Authentication Radio Button
Navigate to the User Mapping Page

m Place a check mark next to the AccessControl Database.

= At the "Database role membership for: AccessControl" section, place a check mark next

to db_datareader and db_datawriter

Click [OK]

e Close out of SQL Management Studio

e Restart the LS Application Server service and IIS
Note: IIS can be reset in command prompt by typing IISRESET and hitting enter

¢ Verify the .NET version is 4.0

)

o

)

Right-click Computer and select Manage. The Server Manager opens

In the left pane, select IIS. Servers are shown in the right pane

Right-click on the proper server name

Select Internet Information Services (I1S) Manager

On The Internet Information Services (IIS) Manager window, select Server Name > Sites >
Default Web Site



o Make sure that the ASP.NET version is set to 4.0 which it should be by default. To check:
m Double-click NET Compilation
= Expand Assemblies. Confirm that the system version is 4.0

Verify IIS Permissions

o From Server Manager click Tools > Internet Information Services (I1S) Manager

o Expand the server > Sites > Default Websites

o Click on Application Pool and verify the LS AppPool .NET setting is 4.0

= [fit is not right click on LS AppPool > Basic Settings and change the .NET CLR version to
4.0

Click on each of the following Connections names from the left pane and double click
Authentication. We want to verify each have Anonymous Authentication and Windows
Authentication enabled:

o Lnl.OG.Web

o Lnl.OG.Services

o IDVMHost

o AdminApp

o FrontDeskClickOnce

o KioskClickOnce

Visitor Management Host Configuration
o Navigate to CAinetpub\wwwroot\Lnl.OG.Services\ldvmWebHost\
= Open and copy all content from the desired protocol’s config file below:
= HttpWithWindowsAuthenticationServices.config
= HttpsWithWindowsAuthenticationServices.config
o Open Services.Config and paste the previously copied config file replacing all of its contents
then save changes
Navigate to C\Inetpub\wwwroot\Inl.og.services\WebHost and edit the
FlexApplicationConfiguration.xml file
o Locate the URL and verify after the Http:// it has the FQDN of the server. The line should look
something like: http://tsg-72269b.tsg.lenel.com/Lnl.OG.Services/IdvmService svc?wsdl
Note: If using SSL change the HTTP to HTTPS
o Save if changes were made to the file
Navigate to C\Inetpub\wwwroot\AdminApp and edit the SilverlightApplicationConfiguration.xml
file
o Locate the line var g_Inl_pfx_webservice_serverAddress and verify the ServerAddress is the
FQDN
Note: If using SSL replace HTTP with HTTPS
o Save if changes were made to the file
Navigate to C\Inetpub\wwwroot\Inl.og.web\ and edit the Preferencess file
o Locate the URL and verify after the Http:// it has the FQDN of the server. The line should look
something like: http//tsg-72269b.tsg.lenel.com/Lnl.OG.Services/IdvmService svc?wsdl
Note: If using SSL change the HTTP to HTTPS
o Save if changes were made to the file

Client and server browser configuration



o From the Tools menu in Internet Explorer, select Internet Options
o Select the Security tab
o Select the Trusted sites icon and then click [Sites]
m Type the URL for the OnGuard server on which the Web site is hosted
= Click [Add]
Note: You may need to uncheck Require server verification (https:) for all sites in this
zone
s Click [Close]
e Click [Custom level]
o Locate the following settings in the list and verify that they are set correctly:
= ActiveX controls and plug-ins > Automatic prompting for ActiveX controls — Enabled
= Downloads > File Download — Enabled
= Miscellaneous > Access data sources across domains — Prompt
m Scripting > Active Scripting — Enabled
s User Authentication > Logon — Automatic logon with current username and password
e Set the Reset to drop-down menu to Medium-low
o Click [Reset]
o Click [OK]
o Awarning dialog may open. Click [Yes]
e On the Advanced tab, select Multimedia > Play animations in web pages
e Click [OK] to close the Internet Options dialog

e Installing the Server Digital Certificate in Internet Explorer if Using SSL (HTTPS)
o In Internet Explorer, open https:;//
o Click [Continue to this website (not recommended)] to view the web page
o At the Security Warning, click [Yes]
o Inthe Address Bar, click [Certificate Error]
o Click [View Certificate]
o Click [Install Certificate] the Certificate Wizard opens
o Click [Next].
o Select Automatically select the certificate store based on the type of certificate
o Click [Next]
o Click [Finish]
o Click [OK]
o Click [OK]

e Testing the IDVM Web Service
o Go to http(s)//ServerFQDN/LNI.OG.Services/IdvmService.svc
o You should see a page similar to the one on the below:



Custom Setup Information El

i Flease note that the "Application Server" will not be presented as a selectable server Feature during custom
\“) setup on this system because 115 is not installed.  IF wou wish to install the web-based "Application Server®
feature, please cancel this installation and inskalliconfigure IS first,

o Ifyou are on a domain you should see the Fully Qualified Domain Name of the server running
I1S on the link after “svcutil.exe”. This is necessary if you will be running IDVM Host.
o Ifyou are on a domain and you don’t see the FQDN for the server, you need to do the
following:
= Open IS, go to the bindings of Default website on port 80. Edit the bindings and add
under Host Header Name the FQDN of the IS server
s Restart lIS
= Go back to http(s)//hostname/Lnl.OG.Services/IdvmService.svc and confirm that now you
have the FQDN on the link
s [fyou still see only the server name, copy crossdomain.xml to wwwroot and restart 1S
and LS Application Server

e Click on the link after svcutil.exe, you should see an image similar to:

<7xmi version="1.0" encoding="UTF-8"7>
<wsdl: aefmtmns xmins:wsam="http://www.w3.0rg/2007/05/addressing/metadata” xmins:wsal0="http:// www.w3. org/zuns/ns/addressmg xmins: wsp="http://schemas.xmlsoap.org/ws/2004/09 /policy”
="http:/ / schema: _com/ws/2005/12/wsdl/contract” xmlns:wsaw="http:/ /www.w3.0rq/2006 / 05/ g/ wsdl" : "http:/ / _xmlsoap.org/ws/2004/08/addressing/policy"
xmins:wsx="http:/ /schemas.xmlsoap.org/ws/2004/09/mex" xmins: wsa="http: / / schemas.xmlsoap.org/ws/2004/08/. i “hittp:, 1 7services Jal. com/2008/06/Types" xmins:soap12="http://schemas.xmlsoap.org/wsdl/s0ap12
ttp:/ /schemas.xmlsoap.org/wsdl/soap/* xmIns:wsu="http:/ /docs.oasis-open.org/wss/2004/01/oasi: y-1.0.xsd" http:/ /schemas.xmlsoap.org/soap/encoding/"
xmlns:xsd="http:/ /www.w3.0rg/2001/XMLSchema" "http:/ fschemas.xmlsoap.org/wsdl/" “http://services.Inl.com/2008/06/ Types" name="IdvmService'>
+ <wsp:Policy wsu:1d="BasicHttpBinding_IIdvmService_policy">
- <wsdl:types>
- <xsd schema largetNamEspace- "http://services.Inl. comlzoualuBlTypes xmins:ser="http:/ /sch: i com/2003/10/Serialization/" mDefault="qualified">
name="ListTyp
- <xsd:complexType>
- <xsd:sequence>
< name="Rex type=" ontext" nillable="true" minGccurs="0"/>
name="T ist" type=" ist" nillable="true" minOccurs="0">
</xsd:sequence>
</xsd:complexType>
</xsd:element>
- <xsd:complexType name="RequestContext">
- <xsd:sequence>
<xsd:element name="SecurityContext" type="tns:SecurityContext" nillable="true" minOccurs="0"/>
<xsd:element name="International" type="q1:International" nillable="true" minOccurs="0" xmins:g1="http://www.w3.0rg/2005/09/ ws-i18n"/>
</xsd:sequence>
</xsd:complexType>
<xsd:element name="RequestContext" type="tns:RequestContext" nillable="true"/>
- <xsd:complexType name="SecurityContext'>
- <xsd:sequence>

name=" " type="xsd:string" nillable="true" minOccurs="0"/>
names= type= ing" nillable="true" minOccurs="0"

<xsd:element name="AuthToken" type="xsd:string" nillable="true" minOccurs="0"/>
name=" VId" type="xsd:int" nillable="true" minOceurs="0"/>

e IDVM Admin App
o Used only to configure sign-in locations for Visitor Self Service and kiosks
o URL:
o Allows login with either an internal OnGuard account or with directory account that is linked
to an OnGuard user



e IDVM Host

o Web based client that allows hosts to create and modify visits without needing System
Administration or Visitor Management thick clients

o SSOURL:

o Non-SSO URL: ?useAutomaticSSO=false

o To use IDVM Host, the host’s directory account needs to be linked to an OnGuard user with
the appropriate permissions. Refer to the Visitor Management Host user guide for the
necessary permissions.

o The host's directory account also needs to be linked to their Cardholder profile in System
Administration

o The host will need to have the “Allowed Visitors” checkbox checked in the Visits tab of their
Cardholder profile

Troubleshooting

e Directories not loading in IDVM Host
o You may need to wait longer for the directories to load. It can take up to a few minutes the
first time
o FlexApplicationConfiguration.xml - check line 2 to verify it does not have “LocalHost” instead
of the FQDN of the server. If corrected restart LS Application Server and IIS.
o The URL being used must match what is in the FlexApplicationConfiguration.xml exactly
o Verify the settings within System Administration are correct:
= You need to first create a Directory in OnGuard's System Administration
= You need to link a Cardholder to a Directory account in OnGuard
= You need to link a Cardholder to a Directory account in OnGuard
s Under Users | System Permission Groups tab, the permission group for your users must
have "User directory accounts" checked

¢ Error Message "You are being logged out because you do not have permission to host visits.
Please see your administrator."
o Verify the “Allowed Visitors” checkbox in System Administration > Cardholders > Visits is
checked
Note: This box can only be checked for Cardholders. If the person type is Visitor it cannot be
checked

¢ Emails are not being sent when | create a visit in IDVM Host

o Verify the Global Output Service is configured and try sending a test email of an event from
Alarm Monitoring. If the email was not received refer to KB 1533 for additional Global Output
troubleshooting.

o In System Administration navigate to Administration > Cardholder Options > Visits and verify
“Include host's email by default” and “Include visitor's email by default” are both checked.
These settings are not turned on by default.

o Verify an email field is present on the Visitor form. On the Cardholder form click Search and
change the Person Type drop down to Visitors then click OK. In some cases the email field will



be missing however it can be added to the form but it will require the full version of
FormsDesigner.

s Create a database backup

= Log into FormsDesigner and select the Visitor form

= Navigate to Insert > Text Field and create a box on the form

= Match the settings to the provided screenshot

Visitor E-mail [EMAIL] Properties = N
General Settings | Forts | Field Settings | Field Styles |
Object name:  Visitor E-mail [ Required
Field rame:  EMAIL D‘U”::id
Type: [Text =
Length: 80 Decimals: |0
Date format: | Short date, no time
Defaut:
Template: Key 3>
vCard: [Intemet Emai -
asc: | -]
CAC ron PIVY: | -]
DMV/Passpot: | -
PIv: | -]
PIV: | -
FASCH: | -]
0K | [ Cancel ][ Hep

e Insert a label for the new text field. Give it an object name of Visitor Email Label. In the Assigned
field drop down list select Visitor Email (or whatever name was given to the text field in the above
step.)

e Click on Save then select Save and PRESERVE any existing user defined cardholder data (Slowest)

e Once the save completes restart the LS Application Server service

e Create a new visit from IDVM Host and test that email was received

e LS Application server starts then stops
o FormsTranslator must be run prior to using the web applications
o Navigate to the root of the OnGuard installation and run Lnl.Tools.FormTranslator.exe

¢ Error Message “Could not sign out visit event. The badge status for sign out must be
configured.”
o In System Administration navigate to Administration > Cardholder Options > Visits
o Click Modify then select the desired value for “Badge status for sign out”
o Click OK

¢ Is there an Auto Log off option with our web apps?
o No, there is no way to set a logoff time for our web applications



e Error about Javascript needing to be enabled for this page to display
o From Internet Explorer navigate to Tools > Internet Options > Security > Trusted Sites >
Custom Level
o Find the option under Scripting “Scripting of Java Applets” and enabled it
o Click OKtwice to close out of Internet Options

e SOAP Errors
o SOAP errors typically point to issues with permissions. Verify the following areas were
correctly configured as per this document:
» Create a domain admin account for the LS Application Server
= The userrunning the LS Application Server service has full Permission to wwwroot and all
of its subfolders
= Add the SQL login for the user
= Start the LS Application Server service using the above domain admin account
= |IS was correctly configured prior to installing OnGuard

If 1S was not installed the following error will show
= |fIIS was not installed prior to the LS Application Server, you will need to either
uninstall and reinstall OnGuard

e HTTP 401 or HTTP 404 Not Found when browsing to
o You may get this error, even though the file DOES exist and you can even browse to this file
by going to http:///Lnl.OG.Services/.
o Verify that .NET Framework 3.5 is enabled, expand it out and also enabled HTTP Activation
o Verify NET Framework 4.5 is enabled, expand it out, verify that WCF Services are enabled,
expand it out and enable HTTP Activation

Applies To
OnGuard up to 8.0
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